VERSION ACTUAL :

Inicio de sesión

Raulito el Friki

Raulito El Friki

COMENTARIOS

EN LINEA

Hay actualmente 0 usuarios conectados.

NUEVOS

  • pedronavia
  • Krkmo
  • miguel-angel
  • Jorge Albizures
  • juansan

Se encuentra usted aquí

Salida a WAN fallida

Imagen de Pere Ferrés Pons

Ubicación

Landete
España
39° 54' 27.1692" N, 1° 21' 54.648" W
ES
Forums: 

Saludos:
Soy nuevo en este foro y es la primera vez que posteo un mensaje de socorro.
Mis disculpas por adelantado si en él no son lo suficientemente explícitas.
Acabo de instalar Fedora 25 Workstation terminando correctamente.
El reinicio fue exitoso y la comunicación a WAN (en principio) correcta.
Al configurar el sistema como enrutador/encaminador de la red local todo va según lo previsto menos la navegación desde el servidor a WAN.
Los clientes de la red local se comunican entre si y se conectan a WAN sin problemas.
El problema que tengo es que ni Firefox ni Chromium pueden navegar a WAN y presentan este mensaje:
-------------------------------------------------------------
Comprobar el proxy, el cortafuegos y la configuración de DNS.
DNS_PROBE_FINISHED_BAD_CONFIG
--------------------------------------------------------------
La configuración efectuada es la siguiente:
yum install dhcp dhcp-common
systemctl stop NetworkManager
systemctl disable NetworkManager
systemctl restart network
systemctl status NetworkManager
systemctl status network
Configuración de la interfaz eth1 conectada al Router por DHCP (ISP de Jazztel)
Configuración de la interfaz eth0 conectada a LAN por 192.168.10.1 estática.
systemctl restart network
nano /etc/dhcp/dhcpd.conf
ddns-update-style interim;
allow booting;
allow bootp;
authoritative;
ignore client-updates;
set vendorclass = option vendor-class-identifier;
subnet 192.168.10.0 netmask 255.255.255.0 {
option routers 192.168.10.1;
option domain-name-servers 8.8.8.8, 8.8.4.4;
option domain-name "192.168.10.1";
option subnet-mask 255.255.255.0;
range 192.168.10.1 192.168.10.250;
filename "/pxelinux.0";
default-lease-time 21600;
max-lease-time 43200;
next-server 192.168.10.1;
}
systemctl enable dhcpd
systemctl start dhcpd
systemctl status dhcpd
nano /etc/sysctl.conf
net.ipv4.ip_forward = 1
sysctl -p
yum install iptables-services iptables-utils
systemctl stop firewalld.service
systemctl disable firewalld.service
systemctl enable iptables.service
nano /etc/sysconfig/iptables
*nat
:PREROUTING ACCEPT [0:0]
:POSTROUTING ACCEPT [0:0]
:OUTPUT ACCEPT [0:0]
-A POSTROUTING -o eth1 -j MASQUERADE
COMMIT
*filter
:INPUT ACCEPT [0:0]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [0:0]
-A INPUT -i eth1 -p icmp -m icmp --icmp-type 8 -j DROP
-A INPUT -i lo ACCEPT
-A INPUT -p tcp -m state --state NEW -m tcp -j DROP
-A FORWARD -i eth1 -o eth0 -m state --state RELATED,ESTABLISHED -j ACCEPT
-A FORWARD -i eth0 -o eth1 -j ACCEPT
-A FORWARD -j DROP
COMMIT
systemctl restart iptables
reboot
systemctl restart network
-------------------------------------------------------------

Esta configuración me funciona sin problemas con CentOS 7 1611
¿Dónde está mi error de configuración y/o procedimiento con Fedora 25?
Muchas gracias por la ayuda.

Imagen de Pere Ferrés Pons

Resuelto temporalmente:
Averiguado que /etc/resolv.conf es/era un enlace a /var/run/NetworkManager/resolv.conf y no existe ese objetivo, seguramente NetworkManager lo crea temporalmente cuando se inicia y está activo, pero lo desactive con systemctl disable NetworkManager.
Emito lo siguiente:
rm /etc/resolv.conf
nano /etc/resolv.conf #configurado con los datos del router
systemctl start dhcpd.service

...... y et VOILÁ el navegador Chromium tiene salida a WAN. OK